Long Duration Event Not Displaying Correctly

Nov 17, 2009 at 8:19 PM

Hi

I have a timeline that has a main band showing 4 hours. The second band shows 20 days and the third band shows 6 months.

If I have a duration event that has a duration lasting 7 days.  The event does not display correctly.  The event teaser shows at the end and when you scroll to the beginning of the event it randomly disappears.


This is the xml for my event:

<data>
<event start="11/11/2009 1:14:18 PM"
end="11/17/2009 1:16:37 PM"
isDuration="true"
color="Blue"
title="Low Priority">11/11/2009 1:14:18 PM - 11/17/2009 1:16:37 PM: Low Priority</event>
</data>

Has anyone experienced this issue and been able to fix it?

Thanks

Coordinator
Nov 17, 2009 at 9:43 PM

Please attach data file plus your xaml or javascript, I will investigate and fix asap.

Nov 17, 2009 at 10:09 PM

Here is how I create the timeline in js:

timeline.AddTimelineBand(timelineHeight - 50, true, "hours", 4, 70);
timeline.AddTimelineBand(25, false, "days", 20, 4);
timeline.AddTimelineBand(25, false, "months", 6, 4);
timeline.Run()
I have modified the timeline code itself slightly so that it gets it's event xml from a wcf service.  The xml I posted above is what the timeline uses to display the events.

While digging into the code, I noticed something that could be possibly be the cause of the issue.  I noticed that when (EventPixelWidth/PixelWidth) is greater than 24 this seems to be when the problem occurs.  In my case it was right around 32091/1334.  I thought maybe this was of significance because it is an hours band and can only display 24 hours or something.

Thanks for your help

 

Nov 20, 2009 at 5:06 PM

Hi

Just wondering if any progress had been made on this issue?

Thanks

 

Coordinator
Nov 29, 2009 at 10:06 PM

Sorry, I'm on vacation now, will be checking the issue after 10th dec.

Coordinator
Dec 13, 2009 at 5:50 PM

should be fixed now, please doublecheck

Dec 14, 2009 at 8:34 PM

Fixed...Thank you very much for your hard work.