Bugs

Apr 21, 2010 at 4:38 PM

i found two bugs, i ported the wpf library for .net 4.0 rtw, then i create my sample data, where i have events without duration like so:

<data>

  <event start="Apr 21 2010 10:00:00 GMT"
         title="Peso"
         color="Blue"
         row="1"
       >
       Peso=50 gramas
  </event>

  <event start="Apr 21 2010 12:00:00 GMT"
          title="Glicémia"
          color="Green"
          row="2"
       >
    Glicémia=300
  </event>

</data>

The 1 event, shows up well, but ehn i resize my window it disappears and soemtimes apears again, soemtimes not.. also.. the date taht is puting the event is 1 our later that the startdate.

I m using this control in our app, and i would provide  feedback of issues i found.. i also want to help you guys if u need to make this mroe powerfull, specially add databind to this ..

since i m using this in wpf, i m loading the data like so i don't use the url is it working bad because of this????

private void timeline_Loaded(object sender, RoutedEventArgs

e)

{

timeline.ResetEvents(

XElement.Load(@"Monet.xml"

 

 

).ToString());

}

Regards

Rui

 

Coordinator
Apr 21, 2010 at 8:34 PM

I'll take a look and will let you know. If you find yourself comfortable with code you can help.

Coordinator
Apr 21, 2010 at 9:46 PM

I could repro it, could not yet find the reason though.

 

Coordinator
Apr 21, 2010 at 10:04 PM

The issue with displaying first event resolved. Please confirm.

Apr 23, 2010 at 11:24 AM

It's working now.

that thing of the date is still one hour late that the date i specify.