No data being displayed

Apr 28, 2010 at 3:32 AM
Edited Apr 28, 2010 at 3:40 AM

Hi everyone,

I have a problem that for the life of me I cannot seem to solve.

I am using Visual Studio 2008

I followed the instructions in the documentation on how to implement this control. When I run my website the control renders successfully with the time bands etc. However, no data is displayed.

But here is what makes it even stranger...

I have downloaded the examples. I extracted the timeline.Web project into it's own folder. When I run it, it works exactly as expected, showing the data for Monet and JFK.

However, I then did the following...

  • I created my own (new) web project
  • I cut and paste the source code of the example Timeline.aspx page into my own aspx page (except that my page-language is VB).
  • I created a ClientBin subfolder and placed Timeline.xap here.
  • I placed the Monet.xml, jfk.xml and Silverlight.js into my web root folder.

When I run my web site, the control is rendered properly...but, the data from Monet.xml and jfk.xml is not displayed. As I said earlier, the source code of the aspx page is exactly as in the example (which works), except the first line which specifies the language. So, for all intents and purposes, I have replicated the example project...but mine does not work and the example project does.

I put alerts in the javascript before and after the "timeline.Urls" statement and both fired as expected. I also put an alert after the .run command and that also fired.

So I'm at a loss as to why this is not working. Any help that anyone could give me would be greatly appreciated.

oh, I should also add that no errors are generated at all.

Thanks in advance,

Mary.

 

 

 

Coordinator
Apr 28, 2010 at 4:29 PM

It is possible that though you include xml files into your project they are not copied in output folder of web site. Please double check that your xml files have "Copy always" property set, otherwise upload me your project in "Issue Tracker" section.

 

Apr 28, 2010 at 11:49 PM
Edited Apr 28, 2010 at 11:49 PM

Andrew,

Thank you for your response. After a  lot of messing around last night I managed to solve the problem.

When I created my fresh (new) web project, I created a new "Website". And it is this that seems to have been the problem.

After all my frustration, I decided to start afresh, so I created a new project...but this time, I created a "Web Application". After setting up the pages and files etc...it worked!!

I can't say I fully understand why the website version did/does not work and the web app does...but now I've got a working solution so I'm all good.

Again, thanks for your response, I appreciate it.

Mary.