Getting a blank page when I run the application. What am I doing wrong??

Aug 21, 2010 at 12:49 AM

Hello everyone

I am new to this project. When I downloaded the application and ran it, I got a blank page. I checked that Url parameter is correctly maintained as  Url="http://localhost:4444/Monet.xml" /> (ie i didnt change anything after downloading. But i still get a blank page. Any idea what I'm doing wrong?

Thanks all!


Aug 21, 2010 at 3:07 AM

Sorry, but I have to ask these first. Did you download it from Source Code page or from Downloads page? Did you change the code in any way? There are many samples there, which one is not working?

Aug 21, 2010 at 3:09 AM

BTW, do you have the control at all on the screen or you have just empty browser window?

Aug 23, 2010 at 7:20 PM

Hi Andrew I have downloaded the Silverlight and WPF Timeline Control Ver 1.0 (Wed Nov 11 2009). I downloaded it from the home page. However I am using Visual Studio 2010 and when I tried to open the project using VS 2010, I was asked to convert it since it was created using an older version of Visual Studio. The conversion wizrad automatically made some changes to a few files. Beyond that I haven't changed anything in the files. I just built the whole solution and pressed 'F5' to debug it. Then I just get an empty browser window (no control at all). Is it something to do wth my Visual Studio version (.NET Framework 4.0)



Aug 23, 2010 at 8:56 PM

Try to download it from Source Code Nov 2009 does not support .net 4/SL4

Aug 24, 2010 at 7:28 PM

Thanks for your help. I downloaded the latest version from the Source Code. ( Does this support .NET4? While opening this project in VS 2010 I am being asked for credentials to connect to the Team Foundation Server. I tried using my codeplex username and passwd and they were not accepted. Can you please tell me how I can get access to the Team Foundation Server? (I am getting this error: TFS30063: You are not authorized to access



Aug 24, 2010 at 7:54 PM

You should not need this. Just hit cancel on that dialog.

Aug 24, 2010 at 9:56 PM

Hi Andrew

I was able to open the project successfully and build it successfully ( : latest version) . However when I run it, I get a blank page (no control). I checked that the Target .NET framework version is 4 and the Silverlight version is 4 for projects. I have installed the following on my laptop:

- Visual Studio 2010
- Silverlight Tools for VS2010 :
- Silverlight Toolkit (April) :
- Silverlight Developer Runtime :

Am I missing something?



Aug 24, 2010 at 10:22 PM

That is indeed strange. Can you see the control samples from Home page of this site?

Aug 24, 2010 at 10:26 PM

You mean these? - example with some custom styles - simple example that uses default styles

Yes, I can open them and they work perfecly fine and I can play around with them.

Aug 24, 2010 at 10:31 PM

OK. You have silverlight than :). First, try to run WPF samples.  Next, create new silverlight application project, to see that silverlight tools are correctly installed. if this is still not working after (btw, did you try all samples and they all not working?).