WPF Timeline inside a UserControl Errors

Nov 18, 2009 at 8:35 AM

Hi,

When I use the timeline inside a user control I get the following errors at runtime and adding the control to an existing page in Blend:

Assertion Failed

at TimelineBuilder.CalculateEventRows()

TimelineBuilder.cs(172)

TimelineBand.cs(1013)

TimelineTray.cs(277)

 

The user control has exactly the same code as your example.  Is this a known issue? 

Thank You

 

 

Nov 30, 2009 at 3:37 PM

Hi

I have the same problem.

I think that the problem is that the url-list is'nt initiated correctly.

When i debug i dont get any items back from my xml-file.

/SebulbaSe

Dec 9, 2009 at 11:27 AM

Has anyone discovered a fix for this?

 

 

Coordinator
Dec 13, 2009 at 7:02 PM

I could not repro the problem. Could anyone create a bug and attach example project. Thanx

Dec 14, 2009 at 9:48 AM
andrewsyrov wrote:

I could not repro the problem. Could anyone create a bug and attach example project. Thanx

 Hi,

I have fixed a sample.

Couldn't figure out how to attach a file here so i uploaded it under sourcecode and patch. ID: 4652.

Hope it helps and thanks for a good work.

/SebulbaSe

Dec 14, 2009 at 12:47 PM

Hi again...

I have some more info.

When i start the page its all blank (or mabey i should say brown). Only the navigation arrorws are visible. And if i press any of them i get an error message.

But if I resize the browserwindow (I use IE 8) then i get the years at the bottom and the lines. And if i then press the "Reset Events" button then i loads all the information.

/SebulbaSe

Coordinator
Dec 14, 2009 at 5:51 PM

Should be fixed now, please verify.

Dec 15, 2009 at 8:05 AM

Hi Andrew,

Unfortunately I experience the exact same problem with the latest build you have uploaded.  I downloaded the latest build (36981) and on running the example you include - WPFTimelineExample it fails with Assert Failed again.

thanks

 

 

 

 

Coordinator
Dec 15, 2009 at 3:38 PM

This is indeed strange, because I do not have this Assert. OK, I will do clean install and doublecheck. So, you just downloaded latest build run WPFTimelineExample without any changes and it asserts?

Dec 15, 2009 at 4:12 PM

Hi.  Yes I downloaded the latest build and just changed the startup project to the WPF Sample Application.

 

 

Dec 22, 2009 at 9:44 AM

Hi.

Just want to say that it work for me now.
(I use it in silverlight 3 and VS2010)

Thanks for a great job!! =)

/SebulbaSe